Folgende Anforderungen sind für den Betrieb von @enterprise notwendig

Der @enterprise-Server ist vollständig in Java implementiert und setzt in der aktuellen Version auf JDK 1.8 auf. Dabei werden alle Java-Version ab 1.8 unterstützt.
Der Server kann auf folgenden Plattformen installiert werden:
  • Windows Variants (2008, Win7, Win8, Win 8.1, Win 10)
  • Linux
  • AIX
  • Solaris
Als Datenbank unterstützen wir:
  • Oracle 9i oder höher
  • Microsoft SQL Server 2008 oder höher
  • MySQL 5.0
  • DB2 9.7 oder höher (Windows oder AIX)
  • Derby 10.5.3.0 oder höher
  • PostgreSQL 8.4 oder höher
  • Firebird Version 2.5 oder höher (experimental)
Als @enterprise-Client wird ein Web-Browser verwendet. Wir unterstützen zur Zeit folgende Browser:
  • MS Internet Explorer 11 oder höher
  • Firefox 44.0 oder höher
  • Safari 11.0 oder höher
  • Chrome 48 oder höher
Bei der Initialinstallation von @enterprise (ohne Datenbank) werden 200 MB Speicherplatz benötigt. Abhängig von den laufenden Applikationen, abgelegten Daten etc. steigt dieser Speicherbedarf.

System-Architektur

@enterprise ist modular aufgebaut, um größtmögliche Flexibilität bei der Anpassung zu gewährleisten.

Als Client kommt entweder ein Standard-Web-Browser oder unser Java-Client zum Einsatz. Der Web-Browser kommuniziert über das HTTP-Protokoll mit dem systemeigenen HTTP-Server. Dieser reicht die Anfragen an das HTML-Interface weiter, welches wiederum mit der Workflow-Engine kommuniziert. Die Datenbank wird über einen JDBC-Treiber angebunden.
Fremdapplikationen können über Java-RMI oder Corba direkt auf das API zugreifen.